Mozilla issued a security update stating that the newly released Thunderbird 52.4 , Firefox 56 and Firefox ESR 52.4 patch 10 vulnerabilities, two rated critical, five high and three moderate found in earlier iterations of the software.

Mozilla issued a security update stating that the newly released Thunderbird 52.4 , Firefox 56 and Firefox ESR 52.4 patch 10 vulnerabilities, two rated critical, five high and three moderate found in earlier iterations of the software.

The two critical issues were CVE-2017-7793 and CVE-2017-7810. The first is described as a use after free flaw in Th that can take place in the Fetch API when the windows is freed while still in use possibly leading to an exploitable crash. A use-after-free vulnerability can occur when manipulating arrays of Accessible Rich Internet Applications (ARIA) elements within containers through the DOM, Mozilla explained.

The latter concerns memory safety bugs that showed evidence of memory corruption issues that if left unpatched Mozilla believes could be exploited to run arbitrary code.

The five high-rated problems CVE-2017-7824, CVE-2017-7819, CVE-2017-7805, CVE-2017-7793 and CVE-2017-7818 can all lead to a potentially exploitable crash if not corrected.

The first takes advantage of a buffer overflow situation that takes place when drawing and validating elements with the ANGLE graphics library.

The remaining four are additional use-after-free problem with CVE-2017-7819 occurring in design mode when image objects are resized and if objects referenced during the resizing process have been freed from memory it creates a situation that could allow for the exploitable crash. CVE-2017-7805 references a v vulnerability takes place during transport layer security 1.2 exchanges when it some cases the handshake hashes transcript exceeds the space available in the current buffer requiring the allocation of a new buffer.

“This leaves a pointer pointing to the old, freed buffer, resulting in a use-after-free when handshake hashes are then calculated afterwards. This can result in a potentially exploitable crash,” the bulletin said.

CVE-2017-7793 and CVE-2017-7818 can occur in the Fetch API, for the former, while the latter takes place when manipulating arrays of Accessible Rich Internet Applications (ARIA) elements within containers through the DOM, Mozilla said.

This article originally appeared at scmagazineuk.com



Source link

NO COMMENTS

LEAVE A REPLY